Ansicht von 12 Beiträgen - 16 bis 27 (von insgesamt 27)
  • Autor
    Beiträge
  • #6737

    whitenexx
    Teilnehmer

    Ja dann mach das doch und poste endlich die xorg.conf! So kommen wir doch nicht weiter… ❗

    #6738

    me1357
    Teilnehmer

    Hast du beim konfigurieren des x-servers abgesehen von der gewünschten Bildschirmauflösung auch die für deinen Bildschirm passenden Vertikal- und Horizontalfrequenzen ausgewählt?
    Bist du dir sicher, dass der nvidia-Treiber, den du installiert hast, auch verwendet wird?

    #6739

    metalshoota
    Teilnehmer
    me1357 wrote:
    Hast du beim konfigurieren des x-servers abgesehen von der gewünschten Bildschirmauflösung auch die für deinen Bildschirm passenden Vertikal- und Horizontalfrequenzen ausgewählt?
    Bist du dir sicher, dass der nvidia-Treiber, den du installiert hast, auch verwendet wird?

    Sicher bin ich mir nicht, ehrlich gesagt bei nichts unter Linux. Bin noch totaler Neuling ;(
    Aber hier endlich die cfg:

    Code:
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type „man xorg.conf“ at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section „Files“
    EndSection

    Section „InputDevice“
    Identifier „Generic Keyboard“
    Driver „kbd“
    Option „CoreKeyboard“
    Option „XkbRules“ „xorg“
    Option „XkbModel“ „pc105“
    Option „XkbLayout“ „hr“
    Option „XkbVariant“ „nodeadkeys“
    Option „XkbOptions“ „lv3:ralt_switch“
    EndSection

    Section „InputDevice“
    Identifier „Configured Mouse“
    Driver „mouse“
    Option „CorePointer“
    Option „Device“ „/dev/input/mice“
    Option „Protocol“ „ImPS/2“
    Option „ZAxisMapping“ „4 5“
    Option „Emulate3Buttons“ „true“
    EndSection

    Section „InputDevice“
    Driver „wacom“
    Identifier „stylus“
    Option „Device“ „/dev/input/wacom“
    Option „Type“ „stylus“
    Option „ForceDevice“ „ISDV4“ # Tablet PC ONLY
    EndSection

    Section „InputDevice“
    Driver „wacom“
    Identifier „eraser“
    Option „Device“ „/dev/input/wacom“
    Option „Type“ „eraser“
    Option „ForceDevice“ „ISDV4“ # Tablet PC ONLY
    EndSection

    Section „InputDevice“
    Driver „wacom“
    Identifier „cursor“
    Option „Device“ „/dev/input/wacom“
    Option „Type“ „cursor“
    Option „ForceDevice“ „ISDV4“ # Tablet PC ONLY
    EndSection

    Section „Device“
    Identifier „nVidia Corporation G71 [GeForce 7900 GT/GTO]“
    Driver „nv“
    BusID „PCI:2:0:0“
    EndSection

    Section „Monitor“
    Identifier „Standardbildschirm“
    Option „DPMS“
    HorizSync 30-100
    VertRefresh 50-160
    EndSection

    Section „Screen“
    Identifier „Default Screen“
    Device „nVidia Corporation G71 [GeForce 7900 GT/GTO]“
    Monitor „Standardbildschirm“
    DefaultDepth 24
    EndSection

    Section „ServerLayout“
    Identifier „Default Layout“
    Screen „Default Screen“
    InputDevice „Generic Keyboard“
    InputDevice „Configured Mouse“

    # Uncomment if you have a wacom tablet
    # InputDevice „stylus“ „SendCoreEvents“
    # InputDevice „cursor“ „SendCoreEvents“
    # InputDevice „eraser“ „SendCoreEvents“
    EndSection

    #6741

    whitenexx
    Teilnehmer

    Siehste, da ist der Fehler! Der Treiber wird nicht geladen.
    In der Section „Device“; bei Driver kommt „nvidia“ anstatt „nv“ hin. Du nutzt im Moment noch den OpenSource Treiber, also nicht den neuen, den du vorhin installiert haben solltest.
    Schreib das als root mal dahin und speicher die xorg.conf ab. Dann startest du per Strg+Alt+Backspace den xServer neu und der Treiber sollte geladen sein.

    PS. Ich nehme an, sudo aptitude install nvidia-glx-new ist vorhin bei dir ohne Probleme durchgelaufen, oder? (als root ausführen)

    #6742

    metalshoota
    Teilnehmer

    Also mit Root-Rechten müsste ja dann „sudo“ und wie weiter sein? Oder irre ich mich?

    #6743

    whitenexx
    Teilnehmer
    Metalshoota wrote:
    Also mit Root-Rechten müsste ja dann „sudo“ und wie weiter sein? Oder irre ich mich?

    Bei Ubuntu ist es so geregelt, dass du vor einen Befehl „sudo“ schreibst, wenn dieser als root ausgeführt werden soll. Dabei muss man direkt danach meistens noch das Userpasswort eingeben, falls es nicht zwischengespeichert wurde.

    #6744

    metalshoota
    Teilnehmer

    Ja, das weiß ich :) (*stolz*), nur wie öffne ich es dann? Weil eben hattest du ja schon geschrieben, dass ich es mit einem Texteditor öffnen könnte. Nur dann kommt immer der „Berechtigungs-Fehler“.
    Also nehme ich an, ich muss es mit dem Admin-Terminal machen. Nur wie? Oder komplett falsch?

    #6747

    whitenexx
    Teilnehmer

    Hm mach es am besten so:

    1. Öffne eine Konsole
    2. Tippe: sudo su
    3. Passwort eingeben (Nun bist du root)
    4. Tippe: nautilus
    5. Nun läuft der Dateibrowser mit root-Rechten.
    6. Navigiere zur xorg.conf und öffne sie mit dem Texteditor, dieser sollte automatisch die root-Rechte übernehmen.

    Sollte das nicht funktionieren, dann gehste bis einschließlich Schritt 3 und tippst: nano /etc/X11/xorg.conf
    Dann öffnest du die Config mit „nano“ einem sehr einfachen Texteditor für die bash.
    Du editierst die Stellen und speicherst mit Strg+O ab. Mit strg+x beendest du nano.

    #6755

    metalshoota
    Teilnehmer

    Joa läuft danke =)
    Nur der Cube geht noch nicht ganz, aber das sollte ein kleineres Problem sein oder? ;)

    #6756

    whitenexx
    Teilnehmer
    Metalshoota wrote:
    Joa läuft danke =)
    Nur der Cube geht noch nicht ganz, aber das sollte ein kleineres Problem sein oder? ;)

    Was heißt nicht ganz?

    #6758

    metalshoota
    Teilnehmer

    Ich habe nur 2 Desktops
    EDIT: Hab vergessen die anderen 2 du aktivieren :D

    #6760

    nasenbaer
    Teilnehmer

    Hat ich auch zuerst… ;) Jetzt gehen sie nicht mehr weg…

Ansicht von 12 Beiträgen - 16 bis 27 (von insgesamt 27)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.